Why are my photos not ejecting?

Sometimes, you may find that your photo does not eject from the camera after you take a picture, or the protective black darkslide doesn’t eject when you put a new pack of film in your camera. This can be caused by one or more of the following:

  • Weak battery in the film pack or camera
  • The camera itself is defective
  • Corroded battery contacts on the film pack or camera

See below for potential causes and tips on how you can avoid ejection issues for each:

Weak battery in the film pack or camera

Please note that the flash and the ejection of the photo are triggered by the battery of either the camera (for newer i-Type cameras) or the film pack (for vintage cameras). If you leave your camera open for a long time, the battery will be gradually drained. Make sure to close or turn off your camera whenever you aren’t using it, to prevent the flash from constantly charging and draining your camera’s or film pack’s battery.

The camera itself may be defective

If you put a pack of film in your camera and you hear the camera respond with a motor noise but nothing comes out, try to re-insert the pack of film. If that still doesn’t work, try inserting a different pack of film. If the camera won’t eject the darkslide or photos for either pack, then your camera is defective and will need to be repaired. Basically, the part inside the camera that pushes each photo forward isn’t working.

Corroded battery contacts on the film pack or camera

Older Polaroid cameras may have corroded or soiled battery contacts, preventing them from connecting with the battery properly. The contacts in the camera are two copper springs that extend from the bottom of the film compartment. You can either try to clean them with a flat, slim object (such as a flathead screwdriver) or you simply remove and reinsert the film cassette several times, to scratch possible oxidation and corrosion off of the contacts.

No Comments

Post A Comment